C++ Logo


Advanced search

Re: P2581R0: Specifying the Interoperability of Binary Module Interface Files

From: Ben Boeckel <ben.boeckel_at_[hidden]>
Date: Tue, 3 May 2022 15:45:17 -0400
On Tue, May 03, 2022 at 19:33:22 +0000, Gabriel Dos Reis wrote:
> [Ben]
> > `CXX_MODULES`: for any TU which uses `export` (module or partition)
> Can that be CXX_MODULES_INTERFACES instead?

There's already concern that these names are too long as it is. This
name is more specific which is nice.

However, a better long-term solution would require changes on the MSVC
side. The `-internalPartition` flag being the way it is makes users have
to consider the `export` bit. If instead, `CXX_MODULES` can instead be
*any* TU that creates a BMI, the non-standard `module M:part;` impl unit
can then be something that only those that use it have to deal with
(maybe being `-implementationPartition`?). Is there any hope of moving
the flag to being present on the non-standard thing instead of the
standard-compliant unit?



Received on 2022-05-03 19:44:32