C++ Logo


Advanced search

Re: P2581R0: Specifying the Interoperability of Binary Module Interface Files

From: Ben Boeckel <ben.boeckel_at_[hidden]>
Date: Tue, 3 May 2022 10:32:00 -0400
On Tue, May 03, 2022 at 12:48:24 +0000, Gabriel Dos Reis wrote:
> I have a lot to say in this thread, but a request for the CMake folks:
> Please, can we avoid "module headers" or "header modules" as terminology in the community?
> We've settled on "header units". If we need something more than that, please let's work on it.

There are currently three names used:

  - `CXX_MODULES`: for any TU which uses `export` (module or partition)
  - `CXX_MODULE_INTERNAL_PARTITIONS`: for any TU which is a partition
    without `export` and not an implementation unit (needs to be
    separate because of the `-internalPartition` flag is needed during
    scanning; it wouldn't be that important if the non-standard MSVC
    extention needed the flag and this one did not)
  - `CXX_MODULE_HEADERS`: for header units

Would `CXX_MODULE_HEADER_UNITS` be more acceptable? Are the other names
fine? FWIW, further bikeshedding can go here to avoid cluttering the


We can also move to Discourse if it gets too long on GitLab.


Received on 2022-05-03 14:31:15