C++ Logo

std-proposals

Advanced search

[std-proposals] PROPOSAL: Heading back towards automatic storage duration "auto"

From: Liam Graham <liamgraham_at_[hidden]>
Date: Mon, 21 Sep 2026 12:04:58 +0000
Auto in C++ means type deduction but given readability it would be wise to re-allow "auto" as automatic storage duration back into C++

This is tricky because auto carries C++11 compatibility now but you can make it look "auto_storage" but that wouldn't blend in well. Instead you could allow two ways "auto X" type deduction "auto int X" compiler recognises it.

Received on 2026-09-21 12:05:01