Auto in C++ means type deduction but given readability it would be wise to re-allow "auto" as automatic storage duration back into C++
This is tricky because auto carries C++11 compatibility now but you can make it look "auto_storage" but that wouldn't blend in well. Instead you could allow two ways "auto X" type deduction "auto int X" compiler recognises it.