C++ Logo


Advanced search

Re: [Tooling] Dependency format with module details implementation

From: Ben Boeckel <ben.boeckel_at_[hidden]>
Date: Wed, 3 Apr 2019 16:57:05 -0400
On Tue, Mar 12, 2019 at 19:15:20 -0400, Ben Boeckel wrote:
> - Bikeshedding. Feel free to suggest names for fields or the format
> itself, but please refrain from commenting on name suggestions
> themselves (in support for or against). I'll collect up all
> suggestions and we can discuss them in the future once we have the
> semantics nailed down.

Having seen no naming suggestions, I've submitted a patch to GCC which
writes the format specified here with all the `bikeshed-` prefixes
removed (still haven't found the time to write a patch for Clang).

Here are some names for the format itself that we've brainstormed here:

  - sourcedep
  - srcdep
  - scandep
  - semdep (for "semantic dependency")

Personally, I'm partial to "semdep".

Let the bikeshedding begin :) .


Received on 2019-04-03 22:57:23