C++ Logo

SG14

Advanced search

Subject: Re: [isocpp-lib-ext] std::colony name brainstorming
From: Ville Voutilainen (ville.voutilainen_at_[hidden])
Date: 2021-02-10 00:16:23


On Wed, 10 Feb 2021 at 04:17, Jeff Garland via SG14
<sg14_at_[hidden]> wrote:
>
>
>
> On Feb 9, 2021, at 6:41 PM, Nevin Liber <nevin_at_[hidden]> wrote:
>
> 
> On Tue, Feb 9, 2021 at 7:11 PM Jeff Garland via SG14 <sg14_at_[hidden]> wrote:
>>
>> unordered_list
>> unordered_block_list
>> unordered_bucket_array_list
>> unordered_sparse_list
>> unordered_change_list
>> unordered_sparse_collection
>> sparse_agglomeration
>> sparse_aggregate
>> sparse_list
>> sparse_block_list
>> or
>> bucket_list ;)
>
>
> I'm not sure what you want us to do with an unordered set of names.
>
> You are the one championing changing the name to one of these. My advice is to pick the best name, and write up the justification for why it is better than colony and why it is better than all the other names in your set.
>
>
> It’s brainstorming. If I had to pick one I’d say unordered_sparse_list.

return -ENORATIONALE;

I don't understand what the term sparse is supposed to tell me about a
list. If a list isn't sparse, it's broken.
Colony also doesn't behave like a list performance-wise, considering
all of its operations, so I don't know
why we'd suggest that it's a list.


SG14 list run by sg14-owner@lists.isocpp.org

Older Archives on Google Groups