C++ Logo


Advanced search

Subject: Re: [isocpp-lib-ext] std::colony name brainstorming
From: Jeff Garland (jeff_at_[hidden])
Date: 2021-02-09 20:16:56

> On Feb 9, 2021, at 6:41 PM, Nevin Liber <nevin_at_[hidden]> wrote:
>> On Tue, Feb 9, 2021 at 7:11 PM Jeff Garland via SG14 <sg14_at_[hidden]> wrote:
>> unordered_list
>> unordered_block_list
>> unordered_bucket_array_list
>> unordered_sparse_list
>> unordered_change_list
>> unordered_sparse_collection
>> sparse_agglomeration
>> sparse_aggregate
>> sparse_list
>> sparse_block_list
>> or
>> bucket_list ;)
> I'm not sure what you want us to do with an unordered set of names.
> You are the one championing changing the name to one of these. My advice is to pick the best name, and write up the justification for why it is better than colony and why it is better than all the other names in your set.

It’s brainstorming. If I had to pick one I’d say unordered_sparse_list.

SG14 list run by sg14-owner@lists.isocpp.org

Older Archives on Google Groups