Subject: Re: [isocpp-lib-ext] std::colony name brainstorming
From: Jeff Garland (jeff_at_[hidden])
Date: 2021-02-10 07:37:12
> On Feb 9, 2021, at 11:16 PM, Ville Voutilainen via Lib-Ext <lib-ext_at_[hidden]> wrote:
> On Wed, 10 Feb 2021 at 04:17, Jeff Garland via SG14
> <sg14_at_[hidden] <mailto:sg14_at_[hidden]>> wrote:
>> On Feb 9, 2021, at 6:41 PM, Nevin Liber <nevin_at_[hidden]> wrote:
>> On Tue, Feb 9, 2021 at 7:11 PM Jeff Garland via SG14 <sg14_at_[hidden]> wrote:
>>> bucket_list ;)
>> I'm not sure what you want us to do with an unordered set of names.
>> You are the one championing changing the name to one of these. My advice is to pick the best name, and write up the justification for why it is better than colony and why it is better than all the other names in your set.
>> Itâs brainstorming. If I had to pick one Iâd say unordered_sparse_list.
> return -ENORATIONALE;
> I don't understand what the term sparse is supposed to tell me about a
> list. If a list isn't sparse, it's broken.
I donât think of lists as âsparseâ â they typically have no extra storage. Nodes are allocated and removed as needed. This âlistâ is special in that it doesnât immediately deallocate storage when removing an element. Itâs a âlist of allocated slotsâ. Then it pulls a nifty accounting trick to allow O(N) traversal - a classic time/space trade.
> Colony also doesn't behave like a list performance-wise, considering
> all of its operations, so I don't know
> why we'd suggest that it's a list.
unordered_map doesnât perform like map either. And as far as I can tell itâs performance properties are unlike any existing container.
My point was from an âinterfaceâ point of view itâs closest to list. Why is it âlist likeâ? First, itâs NOT random access. You have to traverse it. The iterator stability is maintained on modifications. sparse_array might be a good choice â except the dominate features of arrays in c++ is random access and contagious allocation.
Lists come many special forms in computing with slightly different performance properties for different â single linked, double linked, skip lists, etc. To me, this is the closest description of the base functions it provides to users.
Letâs take a look at some of the other âanalogy namesâ that have been suggested. I see âhotelâ, âparking lotâ, and âhiveâ. I like âhiveâ very much. Unfortunately, a hive is random access. Itâs also a âdata warehouseâ project - Apache Hive â meh, Java. Building a new floor on the hotel for each block doesnât really match either â and again, time scales. Parking lot â hmm, I guess you can define linear traversal? It feels like itâs really random access unless itâs one of the Japanese vending machines where you put a car in and it disappears. Ah, but then you use âa keyâ to get it back â oops.
SG14 list run by firstname.lastname@example.org
Older Archives on Google Groups