C++ Logo

SG14

Advanced search

Subject: Re: std::colony name brainstorming
From: Arthur O'Dwyer (arthur.j.odwyer_at_[hidden])
Date: 2021-02-08 12:45:57


On Mon, Feb 8, 2021 at 12:43 PM Ben Craig via SG14 <sg14_at_[hidden]>
wrote:

> The paper talks a lot about the name colony, and that the name “bag” isn’t
> a good fit. I want to see if we can have other good names (or name pieces)
> get discussed on the mailing list.
>
>
>
> For picking names, I like using a name as a way to compare and contrast
> against similar choices. Ideally, the name should indicate why you would
> use one facility over another.
>
>
>
> The big reasons I see to prefer colony over another container:
>
> - Pointer and iterator stability
> - Contiguous block storage for faster iteration (i.e. not a node based
> container)
> - O(1) inserts and deletes
> - Re-orderable / sortable
>
>
What distinguishes colony from slot_map? Is it the lack of "keys"? Is a
colony basically a slot_set?

> I’m leaning towards “*stable_bundle*”. “bundle” communicates a bit of
> disorganization.
>

Or a bit of organization, in the sense that a bundle of papers (or network
cables) is more organized than a non-bundle thereof.
Anyway, "bundle" already has meaning in one of my particular codebases,
whereas "colony" does not — and neither of them is at all useful for
understanding what this thing actually is — so I'd vastly prefer to stick
with the name it's already got.

The time to argue over bikeshed-paint-color is when you're planning to
build a *brand new* bikeshed. There's no point re-painting a bikeshed that
was already built years ago.
(See also: unique_function, function_ref. ;))

–Arthur



SG14 list run by sg14-owner@lists.isocpp.org

Older Archives on Google Groups