C++ Logo


Advanced search

Re: [SG14] [isocpp-lib-ext] std::colony name brainstorming

From: Mark Hoemmen <mhoemmen_at_[hidden]>
Date: Mon, 8 Feb 2021 11:47:06 -0700
On 2/8/2021 10:54, Ville Voutilainen via Lib-Ext wrote:
> On Mon, 8 Feb 2021 at 19:43, Ben Craig via SG14 <sg14_at_[hidden]> wrote:
>> I’m leaning towards “stable_bundle”. “bundle” communicates a bit of disorganization. It still sounds like a container (“a bundle of ints”). I don’t think it has strong precedence in CS unlike so many other names. “bundle” as the root is still rather arbitrary though. Neither part of the name communicates that fast iteration is a key aspect of the container.

Naming is hard! Thank you for suggesting options! : - )

I'm not so much a fan of "bundle." This is a mathematically overloaded
word, e.g., "vector bundle," that suggests a function from one
collection to another -- not what this is. The word also sounds
discrete, like a "bundle of sticks," whereas the data structure itself
is Exactly Not That.

> A "bundle" doesn't mean anything. My jokes about this being a British
> Colony aside, that's not what the name means,
> it indeed means "a distinguishable localized population within a
> species". New members of the population are added,
> old ones go away. The current name describes what it is and what
> operations (especially the population member
> addition/removal) are frequently performed on it. No "skip_*" name
> describes that as well - such names get into
> implementation weeds, rather than describing the higher-level
> semantics of the type.
> So unless there is a superior name that keeps the higher-level
> descriptiveness, keep the current name.



Received on 2021-02-08 12:47:12