C++ Logo


Advanced search

Subject: Re: [SG10] P0018 and P0170: lambda-related changes
From: Nelson, Clark (clark.nelson_at_[hidden])
Date: 2016-03-11 13:45:04

> > I made a couple of proposals for the name of this new macro:
> >
> > __cpp_capture_this
> > __cpp_capture_this_object
> >
> > Any preferences, or alternate suggestions?
> I prefer the second, or perhaps __cpp_capture_this_value.

Hmm. I definitely don't prefer your suggestion. It's ambiguous in a way
that mine is not. (Although, now that you point it out I can see that
mine could be misinterpreted.)

I'll go ahead and throw out another idea that has been in the back of
my head:



SG10 list run by sg10-owner@lists.isocpp.org