C++ Logo


Advanced search

Re: [SG10] P0018 and P0170: lambda-related changes

From: Jason Merrill <jason_at_[hidden]>
Date: Mon, 14 Mar 2016 10:33:07 -0400
On 03/11/2016 02:45 PM, Nelson, Clark wrote:
>>> I made a couple of proposals for the name of this new macro:
>>> __cpp_capture_this
>>> __cpp_capture_this_object
>>> Any preferences, or alternate suggestions?
>> I prefer the second, or perhaps __cpp_capture_this_value.
> Hmm. I definitely don't prefer your suggestion. It's ambiguous in a way
> that mine is not. (Although, now that you point it out I can see that
> mine could be misinterpreted.)
> I'll go ahead and throw out another idea that has been in the back of
> my head:
> __cpp_capture_star_this

I like it.


Received on 2016-03-14 15:33:13