Subject: Re: [SG10] P0018 and P0170: lambda-related changes
From: John Spicer (jhs_at_[hidden])
Date: 2016-03-11 15:02:29
> On Mar 11, 2016, at 2:45 PM, Nelson, Clark <clark.nelson_at_[hidden]> wrote:
>>> I made a couple of proposals for the name of this new macro:
>>> Any preferences, or alternate suggestions?
>> I prefer the second, or perhaps __cpp_capture_this_value.
> Hmm. I definitely don't prefer your suggestion. It's ambiguous in a way
> that mine is not. (Although, now that you point it out I can see that
> mine could be misinterpreted.)
> I'll go ahead and throw out another idea that has been in the back of
> my head:
I was wondering about the names too.
Even though it doesnât fully express the feature, I prefer __cpp_capture_this for its brevity.
There is also some sentiment for getting rid of the existing âcapture this by valueâ semantics that we decided arenât what people really want (i.e., at some point making capture this by value the same thing as the new capture of *this). At that point, we could bump the value of __cpp_capture_this (and all would be right with the world :-)
> Features mailing list
SG10 list run by herb.sutter at gmail.com