Subject: P2266 "Simpler implicit move" needs a name for its feature-test macro
From: Arthur O'Dwyer (arthur.j.odwyer_at_[hidden])
Date: 2021-03-17 12:25:15
At the EWG telecon today, I was convinced that P2266 "Simpler implicit move"
<https://isocpp.org/files/papers/P2266R1.html> needs a feature-test macro.
My question is, what should this feature-test macro's name be? I asked EWG
for suggestions and the answer was "not here, go ask SG10."
#define __cpp_simpler_implicit_move [whatever]
where my understanding is that `[whatever]` will end up being set to the
date of the paper's adoption into the working draft.
Ship it? Or does anyone have relevant thoughts on naming?
SG10 list run by firstname.lastname@example.org