C++ Logo


Advanced search

Re: [SG10] P2266 "Simpler implicit move" needs a name for its feature-test macro

From: Richard Smith <richardsmith_at_[hidden]>
Date: Wed, 17 Mar 2021 10:35:29 -0700
On Wed, Mar 17, 2021 at 10:25 AM Arthur O'Dwyer via SG10 <
sg10_at_[hidden]> wrote:

> At the EWG telecon today, I was convinced that P2266 "Simpler implicit
> move" <https://isocpp.org/files/papers/P2266R1.html> needs a feature-test
> macro.
> My question is, what should this feature-test macro's name be? I asked
> EWG for suggestions and the answer was "not here, go ask SG10."
> I propose
> #define __cpp_simpler_implicit_move [whatever]
> where my understanding is that `[whatever]` will end up being set to the
> date of the paper's adoption into the working draft.
> Ship it? Or does anyone have relevant thoughts on naming?

I think a name with a comparative ("simpler") will age badly. I'd suggest
we either call this __cpp_implicit_move, or perhaps bump the value
of __cpp_rvalue_references.

> –Arthur
> --
> SG10 mailing list
> SG10_at_[hidden]
> https://lists.isocpp.org/mailman/listinfo.cgi/sg10

Received on 2021-03-17 12:35:43