C++ Logo

std-proposals

Advanced search

Re: [std-proposals] A draft for a std::arguments proposal

From: Tiago Freire <tmiguelf_at_[hidden]>
Date: Tue, 1 Oct 2024 10:36:30 +0000
You had said.

>My understanding that the proposed std::arguments (however it is named) is
> equivalent to argv, i.e. std::arguments[0] produces the executable name.
> Is it not?


And I have pointed out that regular argv[0] does not in fact produce the executable name.
It's just the first element in the list of generic arguments, which doesn't have to be the executable name, it could be anything.


________________________________
From: Std-Proposals <std-proposals-bounces_at_[hidden]> on behalf of Andrey Semashev via Std-Proposals <std-proposals_at_[hidden]>
Sent: Tuesday, October 1, 2024 11:49:41 AM
To: std-proposals_at_[hidden] <std-proposals_at_[hidden]>
Cc: Andrey Semashev <andrey.semashev_at_[hidden]>
Subject: Re: [std-proposals] A draft for a std::arguments proposal

On October 1, 2024 10:38:43 AM Tiago Freire <tmiguelf_at_[hidden]> wrote:

> That's just an unwritten convention, it could be anything. Theoretically
> there's nothing categorically different between argv[0] and argv[1], and
> your argc could even be 0

This still doesn't make the distinction.

>
> ________________________________
> From: Std-Proposals <std-proposals-bounces_at_[hidden]> on behalf of
> Andrey Semashev via Std-Proposals <std-proposals_at_[hidden]>
> Sent: Tuesday, October 1, 2024 1:12:25 AM
> Cc: Andrey Semashev <andrey.semashev_at_[hidden]>;
> std-proposals_at_[hidden] <std-proposals_at_[hidden]>
> Subject: Re: [std-proposals] A draft for a std::arguments proposal
>
> On 10/1/24 01:55, Jeremy Rifkin wrote:
>>
>>> I think, std::arguments name is too generic and may encroach on
>>> something
>>> associated with function arguments in the future. And the name is
>>> confusing
>>> today for the same reason.
>>
>> Good points. I went with std::arguments because that's the form the
>> committee had previously considered.
>>
>> I think program_options and command_line would be confusing, the first
>> because of being different from Boost.ProgramOptions and the second
>> because it's not the full command line, just arguments
>
> What's the distinction? Conventionally, command line is the executable
> name followed by arguments, and that's exactly what argv is. My
> understanding that the proposed std::arguments (however it is named) is
> equivalent to argv, i.e. std::arguments[0] produces the executable name.
> Is it not?
>
> --
> Std-Proposals mailing list
> Std-Proposals_at_[hidden]
> https://lists.isocpp.org/mailman/listinfo.cgi/std-proposals




--
Std-Proposals mailing list
Std-Proposals_at_[hidden]
https://lists.isocpp.org/mailman/listinfo.cgi/std-proposals

Received on 2024-10-01 10:36:34