C++ Logo


Advanced search

Scalable reflection - naming

From: Matus Chochlik <chochlik_at_[hidden]>
Date: Tue, 1 Feb 2022 09:54:14 +0100

I'm aware that there was a SG7 vote that changed the reflection syntax from
`reflexpr(X)` to `^X`.
Was there a vote about changing the names of the metaobject operations from
what was agreed upon in the TS?

for example get_name -> name_of, etc.

Received on 2022-02-01 08:54:25