@John McFarlane For background: https://en.wikipedia.org/wiki/Slab_allocation This is what the colony reminded me of. A special case allocator where all available slots are the same size and allocated in separate blocks. Typical implementations use a free list to find unoccupied slots.

Honestly, "slab_allocator<T>" wouldn't be a bad name IMO, except that it doesn't communicate you can do things like iterate over live entries (not that "colony" does either).

On Mon, Feb 8, 2021 at 1:08 PM John McFarlane via SG14 <sg14@lists.isocpp.org> wrote:
Lot is a shorter word for allotment. To allot is to...
  1. (transitive) To distribute or apportion by (or as if by) lot.
  2. (transitive) To assign or designate as a task or for a purpose.

IIRC, someone once pointed out that colony is -- or almost is -- an allocator. Any ground near there we haven't covered?

On Mon, 8 Feb 2021 at 20:00, Ben Craig via SG14 <sg14@lists.isocpp.org> wrote:

I like the analogy of this data structure to a parking lot quite a bit, and will likely use it while teaching the data structure.


I’m not sure I like using the term ‘lot’ in speech.  Maybe `garage` or `park`?




<begin not serious suggestion>

Instead of speaking about where to put a Car, we could speak of where to put other things that have a similar layout.  Perhaps a place that holds animals?  Then we could have a durable place to put horses.  A stable_stable.

<end not serious suggestion>


From: SG14 <sg14-bounces@lists.isocpp.org> On Behalf Of Kim Nilsson via SG14
Sent: Monday, February 8, 2021 1:48 PM
To: sg14@lists.isocpp.org
Cc: Kim Nilsson <nilekurt@gmail.com>
Subject: [EXTERNAL] Re: [SG14] std::colony name brainstorming


In the interest of brevity, may I suggest std::lot ? A std::lot<Car> seems to convey what a parking lot is.



Kim Nilsson


SG14 mailing list
SG14 mailing list