C++ Logo

SG14

Advanced search

Subject: Re: [isocpp-lib-ext] std::colony name brainstorming
From: kRAkEn/gORe (kunitoki_at_[hidden])
Date: 2021-02-10 11:51:24


std::bunch seems like another good fit. It perfectly describe what it is
and what to expect (ordering is not important)

Cheers

On Wed, Feb 10, 2021, 18:28 Paul M. Bendixen via SG14 <sg14_at_[hidden]>
wrote:

> I'm not much for bikeshedding, which this in deed has turned out to
> be, but I do recognise that there might be some people who might take
> offence with the name colony.
> If we really need another name, the skipfield implementation made me
> think of hopscotch (https://en.wikipedia.org/wiki/Hopscotch).
> You start by drawing the field and see how fast you can skip through
> it, then you at some point add a stone (delete an item) and when you
> need more challenge you draw another one besides the first one.
> If this is not completely correct, I apologise but the description
> made me think of that.
> My beef with this is that it is very implementation specific and
> exposes quite a bit of detail about the underlying structure.
> /Paul
>
> Den ons. 10. feb. 2021 kl. 17.07 skrev Ville Voutilainen via SG14
> <sg14_at_[hidden]>:
> >
> > On Wed, 10 Feb 2021 at 17:54, Jeff Garland
> > <jeff_at_[hidden]> wrote:
> > > True, and that name wouldn’t help the user decide if they want to use
> it like ‘unordered’ does - it actually obscures the function. But, I’m
> actually starting to think that in this case ‘bucket_list’ might really be
> better — I was half joking when proposing, but ‘buckets’ have their own
> analogy here from the real world and from implementations of hashed
> containers. They are often partially empty. You put stuff in and out of
> them. In hash buckets you skip over empty slots in the traversal. Buckets
> get allocated/deallocated as a unit. And it’s pithy ;0
> >
> > Well, it's at least trying to describe the high-level structure of the
> > container. There's some snags, like items moving between
> > hash buckets if you rehash, but not between bucket_list buckets. So I
> > don't think this name describes the element stability
> > much better than the current one, or hive.
> >
> > Toss a coin, Matthew.
> > _______________________________________________
> > SG14 mailing list
> > SG14_at_[hidden]
> > https://lists.isocpp.org/mailman/listinfo.cgi/sg14
>
>
>
> --
> • − − •/• −/• • −/• − • •/− • • •/•/− •/− • •/• •/− • • −/•/− •/• − −
> •− •/− − •/− −/• −/• •/• − • •/• − • − • −/− • − •/− − −/− −//
> _______________________________________________
> SG14 mailing list
> SG14_at_[hidden]
> https://lists.isocpp.org/mailman/listinfo.cgi/sg14
>



SG14 list run by sg14-owner@lists.isocpp.org

Older Archives on Google Groups