C++ Logo


Advanced search

Re: [SG14] [isocpp-lib-ext] std::colony name brainstorming

From: Ville Voutilainen <ville.voutilainen_at_[hidden]>
Date: Wed, 10 Feb 2021 18:06:49 +0200
On Wed, 10 Feb 2021 at 17:54, Jeff Garland
<jeff_at_[hidden]> wrote:
> True, and that name wouldn’t help the user decide if they want to use it like ‘unordered’ does - it actually obscures the function. But, I’m actually starting to think that in this case ‘bucket_list’ might really be better — I was half joking when proposing, but ‘buckets’ have their own analogy here from the real world and from implementations of hashed containers. They are often partially empty. You put stuff in and out of them. In hash buckets you skip over empty slots in the traversal. Buckets get allocated/deallocated as a unit. And it’s pithy ;0

Well, it's at least trying to describe the high-level structure of the
container. There's some snags, like items moving between
hash buckets if you rehash, but not between bucket_list buckets. So I
don't think this name describes the element stability
much better than the current one, or hive.

Toss a coin, Matthew.

Received on 2021-02-10 10:07:03