C++ Logo

SG10

Advanced search

Subject: Re: [SG10] Macro name for N3657
From: Richard Smith (richard_at_[hidden])
Date: 2013-06-19 19:51:26


On Wed, Jun 19, 2013 at 5:36 PM, Nelson, Clark <clark.nelson_at_[hidden]> wrote:
> Here is the concluding message in the thread about the macro name for
> heterogeneous comparison lookup for associative containers.
>
> (Frankly, I didn't try to follow the logic; I was just happy the discussion
> eventually came in for a landing with the authors all satisfied.)
>
> Enjoy. :-)

:-)

My interpretation of the below: this is generic-as-in-templates, just
like generic lambdas, and is appropriate because the feature is to
make the associative lookup function be a generic function.

I would still like to understand why they chose to avoid using
"heterogenenous", but the new name seems reasonable to me now.

> -----Original Message-----
> From: Stephan T. Lavavej [mailto:stl_at_[hidden]]
> Sent: Tuesday, June 04, 2013 11:14 AM
> To: Joaquín Mª López Muñoz; Nelson, Clark
> Cc: Jonathan Wakely
> Subject: RE: Feature-test macro names for C++14
>
> Hmm, that's a good point. I'm fine with "generic" here.
>
> STL
>
> -----Original Message-----
> From: Joaquín Mª López Muñoz [mailto:joaquin_at_[hidden]]
> Sent: Tuesday, June 04, 2013 11:09 AM
> To: Nelson, Clark
> Cc: Stephan T. Lavavej; Jonathan Wakely
> Subject: Re: Feature-test macro names for C++14
>
> Sorry to chime in late, but I object to
> __cpp_lib_transparent_associative_lookup: comparison might be
> transparent, but lookup (which is the feature, comparison only the
> means) is generic. Much as polymorphic lambdas are generic but not
> transparent. My vote goes then to __cpp_lib_generic_associative_lookup
> (but will be happy with whatever the final decision is.)
>
> J
>
>
> El 04/06/2013 19:20, Nelson, Clark escribió:
>> OK, great; I will assume that's the winner, unless I hear some objection.
>>
>> Thanks, all,
>> Clark
>>
>>> -----Original Message-----
>>> From: Stephan T. Lavavej [mailto:stl_at_[hidden]]
>>> Sent: Tuesday, June 04, 2013 10:13 AM
>>> To: Jonathan Wakely
>>> Cc: JOAQUIN M. LOPEZ MUÑOZ; Nelson, Clark
>>> Subject: RE: Feature-test macro names for C++14
>>>
>>> __cpp_lib_transparent_associative_lookup sounds good to me too.
>>>
>>> STL
>>>
>>> -----Original Message-----
>>> From: Jonathan Wakely [mailto:jonathan.wakely_at_[hidden]]
>>> Sent: Tuesday, June 04, 2013 9:29 AM
>>> To: Stephan T. Lavavej
>>> Cc: JOAQUIN M. LOPEZ MUÑOZ; Nelson, Clark
>>> Subject: Re: Feature-test macro names for C++14
>>>
>>> On 4 June 2013 17:23, Stephan T. Lavavej wrote:
>>>> "polymorphic" is problematic because it's already a Word Of Power in
>>> Core and Library (std::is_polymorphic). We should avoid making
>>> "polymorphic" the new "static".
>>>
>>> Ah yes, you did explain that to me in Bristol but I had forgotten it.
>>>
>>>> "generic" doesn't suffer from that problem, but I consider
>>> "transparent" to be more descriptive. Things are generic when they're
>>> templated in some way, but generic things are transparent when they
>>> avoid interfering with arguments and return values. For example,
>>> std::max(const T&, const T&) is generic but not transparent.
>>>
>>> After Stephan's patient reminders why we chose the current word :-) I
>>> think Clark's suggestion of __cpp_lib_transparent_associative_lookup
>>> gets my vote.
>>>
>>>
>> .
>>
>
> _______________________________________________
> Features mailing list
> Features_at_[hidden]
> http://www.open-std.org/mailman/listinfo/features


SG10 list run by sg10-owner@lists.isocpp.org