Hello, I am resurrecting a 5 year proposal I never presented.
It suggests, "auto" in a "constrained auto" scenario can be replaced with a name, which will be a typename, introduced for the current function.