Hi.
Why is there no generic scope guard in the standard library?
I am sure there must have been such a proposal before, probably with an explanation of why it was not accepted, but I couldn't find it.