Hello, 
I have written a formal proposal for alternative naming of the Reflection API, based on a previous reddit discussion 
https://www.reddit.com/r/cpp/comments/dzfgbl/on_current_reflection_api_naming/?utm_source=share&utm_medium=web2x