Date: Wed, 12 Aug 2026 01:33:38 +0300
On Wed, 12 Aug 2026 at 01:29, Henry Skoglund <henry_at_[hidden]> wrote:
> Good idea with a std:: prefix, avoids breaking someone's code that has a
> type called "forget".
Bingo. :)
> What about std::redact()?
I quite like it. After you redact a name, code that follows it
considers the declaration of the name
as having been redacted, and can't name or redeclare the thing. The
name's earlier declaration
is there for cleanup purposes, but for post-redaction naming purposes,
it's just sharpied all over.
Maybe even better names exist, but that's a very explicable analogy,
if you ask me.
> Good idea with a std:: prefix, avoids breaking someone's code that has a
> type called "forget".
Bingo. :)
> What about std::redact()?
I quite like it. After you redact a name, code that follows it
considers the declaration of the name
as having been redacted, and can't name or redeclare the thing. The
name's earlier declaration
is there for cleanup purposes, but for post-redaction naming purposes,
it's just sharpied all over.
Maybe even better names exist, but that's a very explicable analogy,
if you ask me.
Received on 2026-08-11 22:33:57
