C++ Logo


Advanced search


From: Steve Weinrich <weinrich.steve_at_[hidden]>
Date: Sun, 10 Nov 2019 20:45:39 -0700
I was thinking that a non_owned_ptr would be a good std addition. The idea
is to formalize the current convention of using raw pointers to represent
transient pointers (transient_ptr might be a better name).

Aside from a lot of details, it would simply be a template wrapper around a
raw pointer. On destruction, the wrapper would do nothing.

This would allow the enforcement of the intended behavior.

What do you all think?

Received on 2019-11-10 21:48:10