Date: Mon, 31 Jan 2022 17:25:30 -0500
> On Jan 30, 2022, at 7:57 AM, Jonathan O'Connor via SG7 <sg7_at_[hidden]> wrote:
>
> Hi everyone,
>
> Would a clearer name for the has_ellipsis function be is_variadic? "Ellipsis" is just the name of the punctuation we use to express variadic parameters.
I think neither is a great name. Many of us would consider:
template<typename … Ts> void f(Ts … ps);
to be variadic.
I think the TS’ name “is_vararg” is a better choice. I don’t know why the paper didn’t just pick it up (that was the intent).
Thanks for bringing it to our attention.
Daveed
>
>
> Regards,
> Jonathan
>
> ‐‐‐‐‐‐‐ Original Message ‐‐‐‐‐‐‐
>
> On Saturday, January 15th, 2022 at 17:41, Daveed Vandevoorde via SG7 <sg7_at_[hidden]> wrote:
>
>> SG7 mailing list
>>
>> SG7_at_[hidden]
>>
>> https://lists.isocpp.org/mailman/listinfo.cgi/sg7
> --
> SG7 mailing list
> SG7_at_[hidden]
> https://lists.isocpp.org/mailman/listinfo.cgi/sg7
>
> Hi everyone,
>
> Would a clearer name for the has_ellipsis function be is_variadic? "Ellipsis" is just the name of the punctuation we use to express variadic parameters.
I think neither is a great name. Many of us would consider:
template<typename … Ts> void f(Ts … ps);
to be variadic.
I think the TS’ name “is_vararg” is a better choice. I don’t know why the paper didn’t just pick it up (that was the intent).
Thanks for bringing it to our attention.
Daveed
>
>
> Regards,
> Jonathan
>
> ‐‐‐‐‐‐‐ Original Message ‐‐‐‐‐‐‐
>
> On Saturday, January 15th, 2022 at 17:41, Daveed Vandevoorde via SG7 <sg7_at_[hidden]> wrote:
>
>> SG7 mailing list
>>
>> SG7_at_[hidden]
>>
>> https://lists.isocpp.org/mailman/listinfo.cgi/sg7
> --
> SG7 mailing list
> SG7_at_[hidden]
> https://lists.isocpp.org/mailman/listinfo.cgi/sg7
Received on 2022-01-31 22:25:32