In P1885, I introduce the name "text_encoding"  for the class representing the name of a text encoding.
I wonder whether that might conflict or interfere with actual encoding/decoder classes and would like your opinion.

Here are a few possible names:
* Charset (IANA nomenclature, posix)
* text_codec (Qt)
* text_encoding
* text_encoding_name (encoding is used by posix / python / 

Unicode nomenclature would favor encoding (Unicode is a charset of which utf-8 and utf-16 are both are encodings)

if text_encoding remains the name of that class, encoder/decoder can be used for the class doing the actual conversions.

I will further rename "system" to "environment" to be more generic and aligned with POSIX.
(user, environment and system are, for our purpose synonym and intended to mean "the encoding assumed and expected by whatever launched our program).
Environment has the added benefit that it implies neither user or systems which makes it more friendly to embedded platforms

Thanks for your input,