Hi all-

as per the last meeting there was some support for putting forward a proposal for what I call reorderase (plflib.org/reorderase.htm) but is really just an iteration of the swap-and-pop idiom, optimized (no swap, just move) and extended to range-erase and std::erase_if/std::erase. See the page for more information.

There was some discussion of this back in 2015 by Brent Freidman but he was focused on the erase_if equivalents - which're the worse-performing of the set.

I have a few questions before putting a paper together, the first of which is bikeshedding. I'm pretty settled on the name 'move_pop', for reasons which will become clear, but I am open to suggestions. Please let me know what you think:

Names which aren't appropriate:

Potential names: