My personal preference is for 1.

 

I’m also fine with long, potentially unwieldy names for feature test macro names, as they aren’t high traffic identifiers.  I’ll suggest:

__cpp_lib_ranges_adapters_with_move_only_elements

 

 

From: SG10 <sg10-bounces@lists.isocpp.org> On Behalf Of Michal Dominiak via SG10
Sent: Wednesday, January 12, 2022 1:37 PM
To: sg10@lists.isocpp.org
Cc: Michał Dominiak <griwes@griwes.info>
Subject: [EXTERNAL] [SG10] Feature test macro choice for P2494, Relaxing range adaptors to allow for move only types

 

Hello, SG10!

 

When P2494 was being discussed in LEWG, there were two competing directions for how to handle its feature test macro:

  1. introduce a new feature test macro that indicates this feature specifically; and
  2. bump __cpp_lib_ranges, since other features in flight for ranges have their own feature test macros.

LEWG requested that I ask this group for a recommendation. Personally I'm leaning towards option number 1, since it feels cleaner to me.

 

Additionally, if this group recommends that I go with (1), I'd like recommendations for what the name of the macro should be, because none of the names that I'm coming up with are short enough to be usable, but also long enough to be descriptive.

 

Thanks,

Michał


INTERNAL - NI CONFIDENTIAL