On Wed, Mar 17, 2021 at 1:35 PM Richard Smith <email@example.com> wrote:
On Wed, Mar 17, 2021 at 10:25 AM Arthur O'Dwyer via SG10 <firstname.lastname@example.org> wrote:
At the EWG telecon today, I was convinced that P2266 "Simpler implicit move" needs a feature-test macro.
My question is, what should this feature-test macro's name be? I asked EWG for suggestions and the answer was "not here, go ask SG10."
I propose#define __cpp_simpler_implicit_move [whatever]
where my understanding is that `[whatever]` will end up being set to the date of the paper's adoption into the working draft.
Ship it? Or does anyone have relevant thoughts on naming?
I think a name with a comparative ("simpler") will age badly. I'd suggest we either call this __cpp_implicit_move, or perhaps bump the value of __cpp_rvalue_references.
My second choice is `__cpp_move_eligible`, since this introduces that term of art into the standard.The feature has nothing to do with rvalue references per se.