On Sat, 15 Feb 2020 at 08:33, Federico Kircheis <federico.kircheis@gmail.com> wrote:
On 2/15/20 9:31 AM, Federico Kircheis wrote:
> On 2/15/20 9:25 AM, Jonathan Wakely wrote:
>>
>>
>> On Fri, 14 Feb 2020 at 13:55, Jonathan Wakely <cxx@kayari.org
>> <mailto:cxx@kayari.org>> wrote:
>>
>>     On Fri, 14 Feb 2020 at 13:14, Barry Revzin via SG10
>>     <sg10@lists.isocpp.org <mailto:sg10@lists.isocpp.org>> wrote:
>>      >
>>      > Hi SG10,
>>      >
>>      > What does the group think of the following papers.
>>      >
>>      > "Safe integral comparisons"
>>      > http://wiki.edg.com/pub/Wg21prague/StrawPolls/P0586R2.html
>>      > > In [version.syn] add the feature test macro __cpp_lib_cmp_equal
>>     // also defined in <utility>.
>>      > The paper introduces 7 functions, one of which is cmp_equal.
>>     Should the macro be __cpp_lib_safe_integral_comparisons?
>>
>>     No, the word "safe" is toxic. "integral_comparison_functions" seems
>>     better to me.
>>
>>      > "Improving the Return Value of Erase-Like Algorithms
>>     II:Freeerase/eraseif"
>>      >
>> http://www.open-std.org/jtc1/sc22/wg21/docs/papers/2019/p1115r3.pdf
>>      > This paper suggests no new feature test macro, but affects the
>>     return type of some functions introduced by the free erase/erase_if
>>     paper, should it bump the __cpp_lib_erase_if macro value?
>>
>>
>> I've just realised it should be /integer/ comparison functions, not
>> /integral/ comparison functions. char and bool are integral types, but
>> not supported by these functions. Only the signed and unsigned integer
>> types are supported.
>>
>>
>
> Yes, integer would be more correct.
>
> Federico

Even if

http://eel.is/c++draft/basic.fundamental


--
Types bool, char, wchar_­t, char8_­t, char16_­t, char32_­t, and the
signed and unsigned integer types are collectively called integral types.
A synonym for integral type is integer type.
--

So it does not make a great difference.

Gee, I love this language ;-)

I think "integral" is definitely wrong, "integer" is ambiguous. We think ambiguous is better than wrong, so I'll request an amendment to the motion when we are doing the votes (as recommended by Herb).