On Fri, 14 Feb 2020 at 13:14, Barry Revzin via SG10
> Hi SG10,
> What does the group think of the following papers.
> "Safe integral comparisons"
> > In [version.syn] add the feature test macro __cpp_lib_cmp_equal // also defined in <utility>.
> The paper introduces 7 functions, one of which is cmp_equal. Should the macro be __cpp_lib_safe_integral_comparisons?
No, the word "safe" is toxic. "integral_comparison_functions" seems
better to me.
You mean after adding one "safe" to the working draft that we have an LWG issue to remove, I shouldn't follow that up with adding a different "safe"?
> "Improving the Return Value of Erase-Like Algorithms II:Freeerase/eraseif"
> This paper suggests no new feature test macro, but affects the return type of some functions introduced by the free erase/erase_if paper, should it bump the __cpp_lib_erase_if macro value?
Hmm, I thought LWG asked for a change to the macro.
I implemented P1115 months ago and bumped our macro to 201900 (i.e.
not a real value, but greater than the one in the C++20 draft).