Subject: Re: <stdatomic.h> feature test macro
From: Jonathan Wakely (cxx_at_[hidden])
Date: 2020-09-25 14:29:36
Resending from the right email account....
> We looked at
> in the LWG telecon today. It proposes to add a __cpp_lib_atomic_compat
> It was pointed out that "compat" is a bit generic and could mean different
> things in different contexts. Should we instead name the macro after the
> header? I think that's our policy when there's no reason to do otherwise.
> It's complicated here by the header being <stdatomic.h> and we can't have a
> dot in a macro name.
> Should it be __cpp_lib_stdatomic_h then?
SG10 list run by firstname.lastname@example.org