C++ Logo

SG10

Advanced search

Subject: Re: [SG10] New feature test macros
From: John Spicer (jhs_at_[hidden])
Date: 2018-11-09 13:52:57


“core” was one of the alternatives I suggested to LWG, but they didn’t find that better than “lang”, so I went with their suggestion of “impl”.

John.

> On Nov 9, 2018, at 2:43 PM, Hubert Tong <hubert.reinterpretcast_at_[hidden]> wrote:
>
> Would it be wrong to replace "impl" with "core"?
>
> -- HT
>
> On Fri, Nov 9, 2018 at 11:39 AM John Spicer <jhs_at_[hidden] <mailto:jhs_at_[hidden]>> wrote:
> On Tuesday we discussed a few feature test macros that we want added at this meeting.
>
> At our lunch meeting, we suggested that the language one be named specially because for these features end-users need to test the library one to know if they have both the language feature and the library facility needed to use it. The language macro is primarily of use to library implementors.
>
> __cpp_lang_destroying_delete
> __cpp_destroying_delete
> __cpp_lang_destroying_delete
> __cpp_destroying_delete
>
> LWG did not like this approach. They want all library macros, which require a header to be included before they can be used, to begin with “__cpp_lib”. They also found “lang” no be insufficiently clear as a way to suggest that end-users should not use that macro.
>
> LWG would like to use:
>
> __cpp_impl_destroying_delete
> __cpp_lib_destroying_delete
>
> __cpp_impl_destroying_delete
> __cpp_lib_destroying_delete
>
> These changes are okay with me.
>
> What do you think of them?
>
> The paper that describes the changes is available here:
>
> http://wiki.edg.com/pub/Wg21sandiego2018/CoreWorkingGroup/d1353r0.html <http://wiki.edg.com/pub/Wg21sandiego2018/CoreWorkingGroup/d1353r0.html>
>
> John.
>
> _______________________________________________
> Features mailing list
> Features_at_[hidden] <mailto:Features_at_[hidden]>
> http://www.open-std.org/mailman/listinfo/features <http://www.open-std.org/mailman/listinfo/features>



SG10 list run by herb.sutter at gmail.com