C++ Logo


Advanced search

Re: [SG10] New draft of Jacksonville additions

From: Nelson, Clark <clark.nelson_at_[hidden]>
Date: Wed, 16 Mar 2016 17:14:37 +0000
> On 03/14/2016 07:19 PM, Nelson, Clark wrote:
> > The only question that doesn't seem to have been settled yet is
> the
> > name of the macro for this-capture. The contenders seem to be:
> >
> > __cpp_capture_this
> > __cpp_capture_star_this
> >
> > Different people have spoken in favor of each. Let the argument
> begin
> > in earnest.
> It seems to me that _star_this is clearer, since we could already
> capture 'this'.

Hmm. I was expecting rather more traffic on this topic. In particular,
John seemed to have a distinct preference, with rationale, for the
shorter, simpler name.

Does no one else have a preference?

> I haven't noticed discussion of the enum class change. Perhaps
> __cpp_enum_class_init?

No, it wasn't discussed on the reflector, but the document does have
my rationale for omitting it. Is it flawed?


Received on 2016-03-16 18:14:48