Date: Mon, 14 Mar 2016 23:19:14 +0000
Here's a new draft. Significant changes:
I deleted the macros identifying all of the brand-new headers, from both
fundamentals and parallelism:
<optional> <any> <string_view> <memory_resource>
<exception_list> <execution_policy>
The proposal (with rationale) is now that non-const data for string
needs no macro, and similarly for enum construction rules.
I have added a macro, with proposed spelling and example (from Richard;
many thanks), for addressof (LWG2296).
The change to fold expressions is represented by bumping the value of
__cpp_fold_expressions. (There will be two adjacent lines in the C++17
table, giving different values to that macro, depending on how many
operators are given a default value.) I deleted the question mark.
Consensus seems to support bumping __cpp_constexpr to indicate that
it can apply to a lambda, so I deleted the question mark.
No one has suggested a better name than __cpp_aggregate_bases, so I
deleted the question mark.
The only question that doesn't seem to have been settled yet is the
name of the macro for this-capture. The contenders seem to be:
__cpp_capture_this
__cpp_capture_star_this
Different people have spoken in favor of each. Let the argument begin
in earnest.
Clark
I deleted the macros identifying all of the brand-new headers, from both
fundamentals and parallelism:
<optional> <any> <string_view> <memory_resource>
<exception_list> <execution_policy>
The proposal (with rationale) is now that non-const data for string
needs no macro, and similarly for enum construction rules.
I have added a macro, with proposed spelling and example (from Richard;
many thanks), for addressof (LWG2296).
The change to fold expressions is represented by bumping the value of
__cpp_fold_expressions. (There will be two adjacent lines in the C++17
table, giving different values to that macro, depending on how many
operators are given a default value.) I deleted the question mark.
Consensus seems to support bumping __cpp_constexpr to indicate that
it can apply to a lambda, so I deleted the question mark.
No one has suggested a better name than __cpp_aggregate_bases, so I
deleted the question mark.
The only question that doesn't seem to have been settled yet is the
name of the macro for this-capture. The contenders seem to be:
__cpp_capture_this
__cpp_capture_star_this
Different people have spoken in favor of each. Let the argument begin
in earnest.
Clark
Received on 2016-03-15 00:19:32