C++ Logo


Advanced search

Re: [wg14/wg21 liaison] [isocpp-sg21] Telecon to review P2388R1 Minimum Contract Support: either Ignore or Check_and_abort

From: Andrzej Krzemienski <akrzemi1_at_[hidden]>
Date: Mon, 27 Sep 2021 10:55:45 +0200
pt., 24 wrz 2021 o 20:04 Gašper Ažman via SG21 <sg21_at_[hidden]>

> I love mailing list debugging.
> And yes, perhaps we should call it "NoCheck" instead of "Ignore".
> We've had a really difficult time figuring out how to word the whole
> thing. Andrzej, you think just removing the [note] bits would work?

I also came to the conclusion that the name "ignore" in the standardese is
misleading. In the next revision we will use something like No_eval.
Regarding the note, I know that this is considered a bug in the
standardese, if we say the same thing in two places. And I am lacking the
expertise to determine if ODR-usage already follows from other rules. In
other places, we do not say everywhere that the expression that we see is
ODR-used. If someone from CWG would be kind enough to shed some light on
this, I would be grateful.


> On Fri, Sep 24, 2021 at 6:44 PM Ville Voutilainen via SG21 <
> sg21_at_[hidden]> wrote:
>> On Fri, 24 Sept 2021 at 19:49, Gabriel Dos Reis <gdr_at_[hidden]>
>> wrote:
>> >
>> > That scenario fails to satisfy the "well-formed program" predicate in
>> my original message:
>> >
>> > >> Finally, for a well-formed program with well-defined behavior fed
>> with the correct data, ignoring contracts (with diagnostics, if one wishes)
>> would be a correct (if poor quality) implementation.
>> >
>> > 😊
>> "Ignore" starts to seem like a Really Bad Name for this, if you ask me.

Received on 2021-09-27 03:55:59